
1. How to start 

 

1.1. Start 
MikroCamLabII (referred to as MCLII) can be opened by double-clicking on the corresponding 

symbol. 

You can also open MCLII from the Start menu and the corresponding icon. 

 

1.2 Open the image/video window 
MCLII detects all installed cameras on the computer. These are listed in the camera list with 

the respective name. 

Selecting the camera list> MikroCamXXX opens the video window with the label. 

The camera is connected via the USB port of your computer / laptop. 

 

 

2. Video window 

 
 
 
 
2.1 Video window 
A: MikroCamLabII 

B: Menu 

C: Toolbar 

D: Camera Sidebar 

E: Folders Sidebar 

F: Undo/Redo Sidebar 

G: Layer Sidebar 

H: Measurement Sidebar 

I: Measurement Sheet 

J: Statusbar 

K: Auto Hide Button 

L: horizontal Ruler 

M: Vertical Ruler 



N: Frame Rate 

O: Frames Captured 

P: Current Video Sizes 

Q: Selected Microscope Magnification 

R: Current Unit 

AA: Sidebar right mouse button context menu 

AB: Video window right mouse button context menu 

AC: Browse window right mouse button context menu 

AD: Image window right mouse button context menu 

AE: Frame window right mouse button context menu 

AF: Double-click brings up Video poperties dialog 

AG: Double-click brings up Magnification dialog 

AH: Double-click brings up Measurement dialog 

AI: Horizontal Ruler or Vertical Ruler right mouse button context menu 

 

2.2 How to close the video window 
Double-clicking on the tab of the opened video window or by clicking on the >x in the same 

line closes the window. 

To close the program completely, click the X in the upper right corner. 

 

 

 

 

 

3. Image window 

 

3.1 Image window 
 

A: MikroCamLabII 

B: Right mouse button will open the Statusbar context menu 

C: The opened file name und directory 

D: Double-click will open file properties dialog 

E: width and height of the current image 

F: Double-click will open the Scale Image dialog 

G: Image Zoom ratio, double-click will zoom the image to 100% 

H: Right mouse button will open the Zoom Ratio context menu 

I: Currently selected Unit 

J: Double-click will open the Measurement dialog 

K: Double-click will open the resolution settings of the current image 

L: Double-click will open the Resolution Settings 

M: Right mouse button will open the Unit context menu 

 

 

3.2 How to close the image window 
3.2.1 Tabbed window 
 

a)  If you have edited an image and want to close it, double-click on the tab, or click on the 

>X in the same line a message window. If you select YES, the changes are saved under 

the same filename and the window is closed. Clicking NO will close the window without 

further reference. CANCEL will abort the closing of the window. 

b) If the opened image is a snapshot of the video window, double-click on the tab, or click 

again on the X in the same line to open a dialog window. If you select YES, the Save As 

dialog opens: 



 

 

Select the drive and the folder where you want to save the image file and assign a 

filename. Then click Save to save the file with the assigned name in the selected 

directory. Click CANCEL to close the Save As window and return to the Picture window. 

Note: Selecting Close window -> All will close all open tabs. 

 

 

3.2.2 MDI window 
 

a) For an opened and edited image window, clicking >X in the upper right corner will result 

in the same operation. The further steps are the same as for the open tab in 3.2.1 a 

b) For a captured image from a video, clicking >X in the upper right corner will result in the 

same operation. The other steps are the same as for the open tab in 3.2.1 b 

Note: Selecting Window -> Close All also closes the video window. 

 

 

 

 

4. Toolbar 
 

When the camera is started or an image is opened, most options are activated in the toolbar. 

This allows quick processing. 

 

 

 
 

1: Open (CTRL + O) 

2: Save (CTRL + S) 

3: Quick Save 

4: Brows (CTRL + B) 

5: Unit 

6: Magnification 

7: Zoom 

8: Video/image Select 

9: Track (enabled if the video / image size is larger than the window) 

10: Object Select: (enabled if an object is opened on a background layer) 

11: Angle 

12: Point 

13: Line 

14: Parallel 

15: Two Parallel 

16: Vertical 

17: Rectangle 

18: Ellipse 

19: Circle 

20: Annulus 

21: Two circles 

22: Arc 

23: Text 

24: Polygon 

25: Calibration 

26: Gray Calibration 



27: Manual Fusion 

28: EDF 

29: HDR 

 

 

5. Camera Sidebar 
 

The camera sidebar is used to control the MCLII camera and contains 17 groups. The 

individual groups contain several functions, which can be opened by clicking on the label. 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5.1 Camera List 
The camera list shows all connected cameras, which are supported by MCLII. Clicking on the 

camera name starts the video window. 

 

 

 

 

 

 

5.2 Capture & Resolution 
Snapshot: Draws a snapshot every time you click, 

Recording: Starts a video recording in the formats wmv / asf or avi 

Live: Select the video resolution 

Snapshot: Select the snapshot resolution 

Format: Specifies the format (RGB / RAW) 

  

 

 

 

 

 

 

 

 

 

 



5.3 Exposure & Gain 
Auto exposure is preset. If you remove the hook, set to manual exposure. Here you can set 

the exposure time and the gain separately. 

Note: High gain results in increased camera noise. A long exposure time reduces image 

repetition. 

 

  

 

 

 

 

 

 

 

 

 

 

 

5.4 White Balance 
Click on the White Balance button to adjust the color of the camera to the specimen. You 

can adjust the temperature and hue manually to make further adjustments. The Preferences 
button returns the adjustments to the initial values. 

Note: For Exposure and White Balance, you will be offered a frame that you can move and 

resize. For highly colored preparations, select an area without sample material for better 

adaptation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

5.5 Color Adjustment 
By moving the individual controls, you can adjust the image according to your needs. The 

Preferences button returns the settings to the initial values. 

 

  

 

 

 

 

 

 

 

 

 

 



 

5.6 Power Frequency 
If the picture is flickering, adjust the frequency of the current source. Enable the anti-flicker 

function. 

  

 

 

 

 

 

 

 

 

 

 

 

 

5.7 Frame Rate 
Change the frame rate, depending on how your laptop / PC can process the refresh rate. 

 

  

 

 

 

 

 

 

 

 

 

 

5.8 Color/Gray 
Select whether to display the image in color or grayscale.  

 

 

 

 

 

 

 

 

 

 

 

5.9 Flip 
If the image is displayed inverted in the video window, you can rotate it with this function to 

fit the eyepiece image. 

 

 

 

 

 

 



 

5.10 Sampling 
For low resolutions, you can set to merge pixels. (Not available on all devices.) 

 

 

 

 

 

 

 

 

 

5.11 Bit depht 
Here you can adjust the depth of color in the video / image window. It can be differentiated 

between 8 bits and 16 bits.  

 

 

 

 

 

 

 

 

5.12 ROI (Region of Interest) 
The image is surrounded by a frame which can be positioned as arbitrary. This is to cut out 

certain areas of the image.  

 

 

 

 

 

 

 

 

 

 

 

5.13 Histogram 
The histogram shows the different color channels. Move the left and right bounding lines, or 

enter an appropriate value. The Preferences button returns the settings to the initial values.  

 

 

 

 

 

 

 

 

 

 

 

 

 



 

5.14 Dark Field Correction 
The function can create a dark image (the camera must be covered). This image is 

subsequently subtracted from the actual recording. In the case of long-term exposures, the 

image noise or artifacts such as hot pixels can be reduced.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5.15 Miscellaneous 
The picture / video is displayed as negative.  

 

 

 

 

 

 

 

 

 

5.16 Parameters 
If you want to save your image settings, click Save. Under Management you can edit the 

stored values. 

  

 

 

 

 

 

 

 

 

6. File 
 

6.1 Open Image: Open an existing image file 

6.2 Open Video: Open an existing video file 

6.3 Open Broadcast: A live video / image of another MCLII user can be displayed (only 

possible if the Internet connection is active) 

6.4 Save: Save the current image 

6.5 Save As: Save the current image with different name and format 

6.6 Batch Save: Saves every open file with current name and file format 

6.7 Quick Save: Quick save 

6.8 Paste as new file: Paste the image file from the clipboard as a new file 



6.9 Twain: Select device: Select cameras connected via a Twain interface 

6.10 Twain: Acquire: Image preview of a twain device 

6.11 Print Setup: Set up the printer 

6.12 Print Preview: Shows the print preview 

6.13 Print: Will print a open image 

6.14 Recent Files: Shows recently opened image files 

6.15 Exit: Will close MCLII 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

7. Edit 
 

7.1 Cut: Cut out a part of the image 

7.2 Copy: Copy a marked zone of the image 

7.3 Paste: Paste a marked zone of an image 

7.4 Add an Abbreviation:  

7.5 Delete File: Delete a marked file in the browse window 

7.6 Select Image: Allows you to drag a selection frame 

7.7 Select All: Drags a selection frame to the whole picture 

7.8 Select None: Cancels the selection frame 

  

 

 

 

 

 

 

 

 

 

 

 

8. View 
 

8.1 Browse: Select an image from the Folders Sidebar 

8.2 Measurement Sheet: Shows the measured values  

8.3 Sidebar: Show or hide additional status bars in the left sidebar 

8.4 Grids: Show or hide different kind of grids 

8.5 Best Fit: Shows the current image with the best fit 

8.6 Actual Size: Shows the image in 100% size 

8.7 Full Screen: Shows the image on the full screen 

8.8 Track: The image is free to move if it is larger than the window 



  

 

 

 

 

 

 

 

 

 

 

9. Browse 
 

9.1 Sort: Sorted images in folder view according to different criteria 

9.2 Icons: The icons can be shown in small or large 

9.3 Refresh: Refresh image files in the current directory 

9.4 Properties: Shows the properties of a marked image 

  

 

 

 

10. Setup 
 

10.1 Start/Pause: Start/Pause the Live view 

10.2 Show Properties: Shows the properties of the Live view 

10.3 Video Overlay: Add additional fades to the image 

10.4 Video Watermark: Provides the possibility to select an image file (bitmap) and insert a 

watermark. The watermark appears in the live image as well as in the captured video 

10.5 Move Watermark: You can change the position of the Watermark in the image 

10.6 Rotate Watermark: You can rotate the Watermark in the image 

10.7 Gray Calibration: You can fit the brightness of the Watermark 

 

  

 

 

 

 

 

 

11. Capture 
 

11.1 Capture Image: You can capture the video image 

11.2 Time-Lapse: With the time-lapse function, you can automatically record multiple images 

at a given time interval. The time interval can be set between 2 and 3600 seconds. The 

maximum number of taken pictures is 9999. In addition, you can give the images a discription 

with time and a name. Choose a suitable file format. Look for available hard disk space. 

11.3 Start Record: Start recording a movie (video format can be wmv/asf) 

 

 

  

 

 



12. Image 
 

If you choose Image the following dialog window will open 

 

  

 

 

 

 

 

 

 

 

 

 

 

12.1 Modus: You can set Color Depth und Gray Scale  

 

 

 

 

 

 

 

 

12.2 Adjust:  
12.2.1 Brightness/Contrast: You can set Brightness and Contrast of the image 

12.2.2 Color: You can set the color value 

12.2.3 HMS: You can set Height/Medium/Shadow 

12.2.4 Curve: You can manually correct the image with the mouse 

12.2.5 Filter Color: You can set a Color Filter 

12.2.6 Extract Color: Show single Color Channels from a color image 

12.2.7 Invert: The image will be shown as a Negativ 

12.2.8 Edge Preserving Smooth:  
12.2.9 Detail Enhance: You can change the detailed view of the image 

12.2.10 Auto Level: Auto assimilation of brightness 

12.2.11 Auto Contrast: Auto assimilation of contrast 

 

 

 

 

 

 

 

 

 

 

 

 

  

12.3 Rotate: Rotates the image in different levels 

 

 



 

12.4 Cutting: You can cut a display detail from the image 
12.5 Image Scale: You can scale the image to another size 

 

  

 

 

 

 

 

 

 

 

 

 

12.6 Histogram: Shows the different color channels of the image 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

12.7 Resolution: You can change the resolution of the image 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



12.8 Mosaic: You can combine open images of the same series to a new image 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 12.8.1 Image List:  
  Available Images: Shows the opened images in MCLII 

  Add: Add open images to the selected ones 

  Add All: Add all open images to the selected ones 

  Remove: Remove a selected image  

  Delete: Delete every selected image 

 

 

 

 

 

 12.8.2 Parameter: 
  Title: Assign a individual title 

  Foot: Assign a individual foot 

  Arrangement: Distribution of the mosaic images on the page 

  Page Size: Page size of the mosaic images 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

13. Process 
 
13.1 Assembly 
This function offers the possibility to combine several images from one specimen to a more 

detailed one. (For this purpose, several images of an image series must be marked) 

 

 

13.2 High Definition Region 
This function provides the possibility to display an image as a high-contrast image and 

reproduces the brightness differences in detail. 

 

 

13.3 EDF (Manual Fusion) 
This function offers the possibility to combine images of a series using 3 different methods. 

- Maximum Contrast 
The images are combined in such a way that the final result is a picture that is as high as 

possible. The elements get sharper, but some details are lost. This method is the 

preferred of the 3 ways. 

- Weighted Average 
The images are combined in such a way to create gliding transitions. 

- FFDSSD Method 
The reference image will be determined automatically 

 

 

 13.4 Deinterlacing 
 No description 

 

 

 

 13.5 Color Composite 
Use the Color Composite dialog box to create and configure color compositions with black-

and-white images. (Function is only active if a B/W image is selected) 

Use this function to combine grayscale images into a color compound. Each group of gray 

scale images which are of the same size, can be mixed in a color composite. Images of 8, 12, 

16-bit integer or floating-point formats are combined into a 24-bit color format. Each input 

channel has individual LUT settings and a registration offset to access it with the other 

images.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



You can also combine individual channels from a single image. Each channel is listed 

separately, as shown below: 

 

 

 

 

 

 

 

 

 

 

Source Images: The Source Images combination field displays the images available for color 

mixing. The source image list is initially filled with a list of currently opened grayscale images. 

The size of the color composite is selected by the first input image. Once entered, the list is 

filtered to obtain only images of the same size as the initial selection. 

 

 

Add: Click Add button to add an image to the mix. You are called up to associate the color to 

the image from the Color dialog box. 

 

Delete: You can use this function to delete selected images from the list. 

 

Color: The Color Box shows the images selected to Color Mixture. 

 

To change the color in the list box, double-click the picture name (the selected color is shown 

in the dialog box), or highlight the name and click the Colors button. 

To delete colors/images from the Colors list box, first click the color/image to highlight it, and 

then press the Delete button. 

 

Color Bars: The image position field on the left side of the color list shows the color assigned 

to each image. The Color List scrolls with the contents of the Colors field. 

 

Set Color: This option determines the color value used for the selected channel in the final 

image display. When you click the Set Color button, the Select Color dialog box appears. 

 

You can choose a color with: 

 

1) Drag the color slider to the desired color in the Color Bar (Range 0 to 359°) 

2) Click the appropriate color button on the color palette. The color bar represents a subset 

of possible colors (pure red, green, blue, cyan, magenta, white) 

3) Select a dye from the list and click the "Select Dye" button. 

 

Note: You can navigate through the Select Color dialog box by using the <Tab> and <Shift + 
Tab> keys to scroll through the items in the dialog box. 

The intensity is determined by the image to which the color is applied. The saturation is 

always 100%. 

The only exception is the white color, which by definition has a saturation of 0%. Selecting a 

value ≥ 360 (dragging the slider to the right) is a choice of white, resulting in a non-colored 

(gray) image. 

 

The elements of the Select Color dialog box are: 

 



Color Bar: The Color Bar shows a rainbow displaying the colors underneath the appropriate 

point of the Color Value slider. 

 

Note: If the Color Value Slider is selected/marked, then you can also control the slider with 

your keyboard strokes. Use the <Page Up>/<Page Down> or only the </> keys to move the 

slider along the Color Bar. 

 

Selected: This color block displays the new color selected with the Color slider bar or color 

palette. 

 

Select Color: The Select Color text field displays the corresponding numerical color value of 

the above-described color block. The selected color is displayed as an HSV color with the red 

value displayed first, followed by the green and blue values. If the color corresponds to a dye 

in the list, the dye name is displayed.  
 

 

 

 

 

 

 

 

 

 

 

 

 

Currently: The Current Color text field 

shows the initially set color of the channel. 

 

Color Palette: The Color Palette is an alternate method to select a color. When you click an 

item in the color palette, the color slider is set to the correct value, and the display is 

updated in both, the selected color block and the selected color box. 

For example, if you click the white button on the color palette, the color slider is set to the 

right. The selected color changes to white, and the selected color text box displays white. 

 

Adjust: The controls in this section are used to adjust the color composite contribution of 

each image, or to the color composite preview itself. You can customize the inserted image 

that is currently selected in the color list by clicking the selected button. If you want to adjust 

the color composite preview use the All button. 

 

Registration: The registration allows you to correct errors of images caused by filter-specific 

optical shifts. Use the directional buttons to move the selected image in the x- and / or y-

direction with respect to the rest of the input images. A click moves this channel one pixel in 

the specified direction. Empty areas are filled with black. Press the 0.0 key to re-center the 

selected image. 

 

The registry shift for the selected channel or the overall image is displayed in the static text 

box below the directional buttons. 

 

Contrast: Use the BCG slider Best Fit and Reset to adjust the contrast of the selected image. 

 



BCG-Sliders: The brightness, contrast and gamma sliders resemble the contrast enhancement 

function in MicroCamLabII. You can set each channel individually or together with the Select 

or All buttons (to the left of the BCG sliders in the adjustment group). 

 

Best Fit: Click this button to perform the best fit of the contrast in the selected area. The 

brightness and contrast settings are then set automatically (gamma is reset to 50). This 

method is identical to the Best Fit contrast setting of MCLII. The Best Fit function is useful for 

initial adjustments. 

 
Reset: Pressing the reset button automatically resets the BCG settings. When the All Modes 

option is set to all, the BCG settings for the overall color image are reset. 

 

Frame: Use the frame slider to adjust the frame of the selected image. (Please note the 

discussion of Color Composite and Image Sequences that follow this section.) 

 

Background: Select one of the available images to display the background color in this combo 

box. The rest of the image planes are subtracted from the background image and display the 

foreground colors without mixing with the background. This is most effective for images 

where the background covers large areas and the other images contain smaller objects. 

 

Background allows the other images to be displayed in front of the background images, 

minimizing color mixing. For example, MCLII can display a red dot on a blue background 

without changing the dot to magenta. If you select None, all images are mixed equable. 

 

New: Click the New button to discard and restart the current color composite image. 

 

The source image combination field is reset to include all grayscale images (including floating 

point fonts). When you select an image from the list, a new join is created with the same size 

as the first selection. As already mentioned, the source image list is filtered to display only 

images with the same size as the initial selection. 

 

 

13.6 Segmentation & Count 
Select Segmentation & Count if the segmentation and number of objects contained in the 

image should be measured. This function offers the user 6 methods. Watershed (W), OTSU 
Dark, OTSU Bright, RGB Histogram, HSV Histogram and Color Cube. Initially, all methods are 

selectable, but as soon as one is selected, the others become inactive.  

 

After the division, adhesions can occur. In this case, the objects can be separated manually 

using the Split Objects function. 

 

When you have the desired results, you can use Count Results to view the statistics and 

analysis results. 

After the end of the count, you have the option to return from step 2 or 3 to step 1 or 2 to 

repeat the split or to perform the Split Objects operation again. (Via the Undo / Repeat 

function in the sidebar) 

 

Note: If you selected None in the Options dialog box, no labels are specified for the metrics, 

area, or scope of the objects, regardless of the method that is selected. But Circles and 

Ellipses can be displayed in the results. This is why the menu is also called Split & Count. This 

function can either specify the segmentation of objects in the image, or the number of 

objects. In this context, we refer to Process -> Segmentation & Count -> Watershed (W) and 

the Count Options. 



13.6.1 Watershed (W) 
The Watershed method is a mathematical-morphological segmentation method based on 

topological theory. The basic idea captures the image as a topological geomorphology on 

geodesy, and each image pixel gray value indicates the height, the boundaries of each local 

minimum value of its impact surface as a catchment area, and the formation of catchment 

areas. The Watershed concept can be described as a simulation of the immersion method. A 

hole is drilled into every local minimum value of the surface and then the entire model is 

slowly immersed in water. Due to the dipping of the indentations and every local minimum, 

the indentation areas slowly expand outwards. From this arise two dams, which form the 

waterside. 

The Watershed method is suitable for a relatively simple target object in the background, as 

well as target objects with a relatively large difference between the background images as 

opposed to the more complex application. 

If you select Process -> Segmentation & Count -> Watershed (W) ..., the following note 

appears: The Segmentation & Count function works exclusively with 24 bits, otherwise all 

further menu items are deactivated. You can change the Color Bit settings to 24 bits under 

Image -> Mode -> Color Quantize. 

 

 

 

 

 

 

 

 

 

 

 

 

Approximations 
"Approximations" include 3 options: 

None: The actual outline of the segmented object is drawn. 

Circle: A circular outline is drawn. The radius of each object is contained in the results of the 

count. 

Ellipse: Contours are drawn in the form of ellipses. The axes of each object are included in 

the results of the count. 

 

With holes 
In the With holes check, the segmented object outlines are marked with color. Meanwhile, 

the holes are marked with color and their parameters are indicated in the picture (the holes 

are marked in grayscale, or similar to the background color). The left image is the result of 

segmentation without the With holes function, the right with the function. The With Holes 

function is usually used to obtain hole parameters. 

 

 

 

 

 

 

 

 

 

 



Outline 
"Style" includes 3 options: 

Outside: The objects are marked by outlines. Its color can be determined by the user. 

Filled: The objects are filled with custom color. 

None: The objects are not marked by any outlines. 

 

Label 
"Method" includes 3 options: 

XOR: The objects are marked with the color indicated for XOR pixels. 

True: The objects are marked by the color you specify. 

False: The objects are not highlighted. 

 

Note: If you select False, no labels are specified for the metrics, area, or scope of the objects, 

regardless of the method that is selected. But None, Circles and Ellipses are displayed in the 

image. This is why the menu is called Segmentation & Count. 

 

Color: The custom color is used to replace the color of the label. If you selected XOR, the 

color selection is not active, but the program marks the divisions in the current XOR pixel 

color. 

 

"Type" includes 3 options: 

Index: The listed objects are marked with numbers. 

Surface: The object surface is marked by an outline. 

Scope: The scope of the object is marked by outline. 

 

 

Area 
Minimum: Determine the lower limit of the area. That means, if the object area is smaller 

than the lower limit value, it will not be registered. 

Maximum: Determine the upper limit of the area. That means, if the object area is larger 

than the upper limit value, it will not be registered. 

 

Perimeter 
Minimum: Determine the lower limit of the perimeter. That means, if the object perimeter is 

smaller than the lower limit value, it will not be registered. 

Maximum: Determine the upper limit of the perimeter. That means, if the object perimeter 

is larger than the upper limit value, it will not be registered. 

 

 

13.6.2 OTSU Dark 
OTSU was developed in 1979 by Japanese scientists and it is a method for determining an 

adaptive threshold, also known as the Otsu method. The method is based on the gradation 

characteristics of the image and divides the image into the background and the target. As 

larger the OTSU between the background and the target is, as greater the difference 

between the two images is. The wrong part of the background, or the wrong part of the 

target, will result in smaller differences between the two parts. Therefore, the maximum 

OTSU means the minimum probability of mis-classification. 

In the OTSU Dark segmentation method, the darker object is segmented from a light 

background using the OTSU algorithm. The counting options correspond to those of the 

Watershed method. 

The image below shows a bright background with dark objects (left) and the result of the 

segmentation (right) as a reference. 



 

 

 

 

 

 

 

 

 

 

13.6.3 OTSU Bright (B) 
In the OTSU Bright segmentation method, the lighter object is segmented from a dark 

background using the OTSU algorithm. The counting options correspond to those of the 

Watershed method. 

 

 

 

 

 

 

 

 

 

 

 

 

 

13.6.4 RGB Histogram 
The RGB histogram segmentation is based on the image histogram in which the image pixels 

are color-processed in a specific area in the histogram. The corresponding range can be 

defined by two vertical lines, or by values in the processing fields. The color that is 

representing the segmented region can be determined by the color selection. For a 24-bit 

true-color image, the segmentation can be performed by the respective R, G, B channels. 

The histogram window is displayed via Process -> Segmentation & Count -> RGB Histogram. 

Each function is given as follows: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



The left value in the selection area of the histogram window corresponds to the position of 

the left vertical in the histogram. This can be changed by entering a value and the 

confirmation with the Enter key. 

 

The right value in the selection area of the histogram window corresponds to the position of 

the right vertical in the histogram. This can be changed by entering a value and the 

confirmation with the Enter key. 

 

The currently displayed color channel in the histogram can be selected here. It can be 

selected between R (red), G (green) and B (blue). 

 

All color channels (RGB) are displayed in the histogram. If this is not selected, only one of the 

color channels is displayed. 

Specifies the color in which the segmented pixels will be displayed in the image. The default 

is green. 

 

The Counting options are opened via the Options button. The counting options correspond to 

those of the Watershed method. 

 

 

 

Example of RGB Histogram: 
1. Open an image, then select Process -> Segmentation & Count -> RGB Histogram. The 

histogram window is displayed. When you move the mouse to the image area, the 

mouse pointer is displayed as a color selection cursor (pipette). 

 

 

 

 

 

 

 

 

 

 

 

 

2. When you move the color selection cursor over the image, the RGB values are displayed 

in the bottom bar of the histogram window. 

3. To set the target exactly, you can set the RGB values of the desired pixels in the initial 

interval. The RGB values can be reset to the initial interval as follows: 

 

R initial interval: 200   ̴255 

G initial interval: 0   ̴ 60 

B initial interval: 0   ̴ 60 

 

 

 

 

 

 

 

 



 

4. When you move the color selection cursor back to any pixel, the RGB values are now 

displayed as 237, 70, and 45 in the example. 

 

It is quickly found that the G-channel, here defined at 60, is too small to segment the 

pixel. The iniNal interval for G can be set from 0 ̴ 60 to 0 ̴ 80 to segment pixels in the 

vicinity.  

Note: If the background pixel of a single channel is within the initial interval, the 

segmentation is not changed. Only if all three channels of the background pixels are 

within the initial intervals, the pixels can be segmented.  

The segmentation effect caused by the readjustment of the initial interval of the G 

channel entry is shown below. 

5. Repeat step 4 and adjust the initial interval of each RGB channel to achieve optimal 

segmentation. 

 

 

13.6.5 HSV Histogram 
The HSV histogram segmentation is based on the image histogram, in which the image pixels 

are color-processed in a specific area in the histogram. The corresponding range can be 

defined by two vertical lines, or by values in the processing fields. The color representing the 

segmented region can be determined by the color selection. For a 24-bit true-color image, 

the segmentation can be performed by the respective H, S, V channels. 

The histogram window is displayed via Process -> Segmentation & Count -> HSV Histogram. 

Each function is given as follows: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The left value in the selection area of the histogram window corresponds to the position of 

the left vertical in the histogram. This can be changed by entering a value and the 

confirmation with the Enter key. 

 

The right value in the selection area of the histogram window corresponds to the position of 

the right vertical in the histogram. This can be changed by entering a value and the 

confirmation with the Enter key. 

 

The currently displayed channel in the histogram can be selected here. It can be selected 

from H (Hue), S (Satiation), and V (Value). 

 

All channels (HSV) are displayed in the histogram. If this is not selected, only one of the 

channels will be displayed. 



Specifies the color in which the segmented pixels will be displayed in the image. The default 

is green. 

 

The Counting options are opened via the Options button. The counting options correspond to 

those of the Watershed method. 

 

Example of RGB Histogram: 
1. Open an image and select Process -> Segmentation & Count -> HSV Histogram. The 

histogram window is displayed. When you move the mouse to the image area, the 

mouse pointer is displayed as a color selection cursor (pipette). 

2. When you move the color selection cursor over the image, the HSV values are 

displayed in the bottom bar of the histogram window. 

3. When you move the mouse to the background area, the HSV values in the example 

are at 214, 87, 228. To set the target exactly, you can set the HSV values of the 

desired pixels in the initial interval. The HSV values can be reset to the initial interval 

as follows: 

 

R Initial Interval: 60  ̴200 

G Initial Interval: 90   ̴130 

B Initial Interval: 0   ̴210 

 

4. When you move the color selection cursor back to any pixel, the RGB values are now 

displayed as 194, 79, and 212 in the example.  

It is quickly found that the S-channel, defined here at 90   ̴ 130, is too small to 

segment the pixel. The initial interval for S can be set to 90   ̴ 130 and 60   ̴ 130 to 

segment pixels in the vicinity. (Note: If the background pixel of a single channel is 

within the initial interval, the segmentation is not changed. Only if all three channels 

of the background pixels are within the initial intervals, the pixels can be segmented.) 

The segmentation effect caused by the readjustment of the initial interval of the S 

channel entry is shown below. 

5. Repeat step 4 and adjust the initial interval of each HSV channel to achieve optimal 

segmentation. 

 

 

13.6.6 Color Cubic 
Process> Segmentation & Count> Color Cubic opens a window named Color. 

 

 

 

 

 

 

 

 

 

 

 

At this moment, the color pipette is activated by default. Click on the image to set a color 

value in the selected area as the basic value. MCLII will segment the image by selecting the 

pixel within the basic tolerance range and mark it with the currently selected color. By 

repeatedly clicking the target pixel, MCLII can continuously insert new pixels within the basic 

tolerance range into the target, thereby achieving continuous segmentation. If some 



unwanted pixels have been added to the segmentation data, the decolorization pipette can 

be used to remove the unwanted pixels. 

This process is very similar to the color pipette function. This means that the average color 

value in the pixel mask area is also set as the basic value by a click with the pipette in order to 

wipe the segmentation data which lie within the basic tolerance color range. (This can 

already be used to divide segmented areas again.) Also describes this process, only easier) 

 

Colorizing Pipette: Collect average color value of the selected pixel mask area as basic value 

and add pixels that are within the basic-tolerance range of the segmentation data. 

 

Decolorizing Pipette: Collect average color value of the selected pixel mask area as basic 

value and deconstruct the segmentation data is within the basic tolerance range. 

 

Mask area: When colorizing or decolorizing with the pipette, a mask area is required to 

calculate the average color value of the clicked image point. The color value of the mask area 

is used as the basic value. Color values within the basic measurement tolerance range can be 

added to or removed from the segmentation data. The default mask range is 3x3, other 

options are 1x1, 5x5, 7x7. 

 

The average RGB values of the mask area. 

 

Tolerance: There are three tolerance values: R, G and B. The user can perform fast and 

accurate object segmentation by selecting a suitable tolerance value. The standard R, G and B 

tolerance values are 10. 

This is used to select the color of the segmented area. The default color is green. 

 

When you click on the Options button, the window with the counting options opens. The 

displayed options are the same as for Process -> Segmentation & Count -> Watershed (W). 
For more detailed information, see Process -> Segmentation & Count -> Watershed (W). 
 

Here's an example to illustrate the Color Cube process. 

 

1. Open an image file 

2. Due to the inevitable noise in the image, an image smoothing operation should first be 

carried out. Various algorithms ensure smooth image operation. This is done as follows: 

After selecting Process -> Filter -> Morphological, the following menu will open. Click OK 

and the smoothed image is displayed as a preview in the right window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

3. Select Process -> Segmentation & Count -> Color Cube ..., then the following menu will 

open. 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. At this moment, the area is checked by the color pipette. Click the pixel you want to 

segment. That is, select the color range you are interested in. If an unwanted color range 

is included in the segmentation area, select the Decolorizing pipette and click the 

unwanted pixels so they are removed. When the segmentation process is complete, click 

OK and the segmentation & count is executed. 

5. Click Options to select Outline, Label, and so on. The primary segmentation is completed. 

 

 

13.6.7 Split Objects 
After segmentation, it can be found that a particle is not a single object, but two separate 

objects. However, they were calculated as a single object. The selection of split objects 

corrects this problem. Object splitting with Split Objects is explained below. (Function is only 

active after one of the previous functions, e.g., Watershed, has been performed) 

 

Move the mouse to the object you want to separate. Press the left mouse button and draw a 

straight line. 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you press the left button, the cursor should not touch the target. The starting point of the 

separation line should be outside the target to be separated. Move the cursor to the right 

side of the target. The end point of the separation line should also be outside the target to be 

separated. Release the left mouse button when this operation is completed. A separation line 

is now displayed between the two contiguous objects. After you release the left mouse 

button, the image is counted again by MCLII. 



If you disable or select the Split Objects menu again, the separator line is dimmed. After the 

dividing line has been hidden, the Split Objects process is completed. The final result is 

shown below. 

 

 

 

 

 

 

 

 

 

 

 

13.6.8 Count Results 
With Count Result you have the possibility to display the statistical results of the image. The 

result window displays the index, center, area and perimeter. The units of the statistical 

results are displayed as selected by the user. If you click on Index, Center, (radius (main and 

secondary axes or none) in this case), the results are sorted by size (ascending or 

descending). If you click on a specific element from the list, it is displayed in the image. 

Meanwhile, index, or area and perimeter, are automatically blanked out. (Function is only 

active after one of the previous functions, e.g., Watershed, has been performed) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The center column in the result is relevant for the approximation option in the Options dialog 

box. When Circle is selected, the radius of the circle is displayed as a radius column, and the 

main and minor axis of the ellipse is listed as an axis column when selecting Ellipse. If you 

select None, no column is displayed. 

 

If you click on Export, the statistical result is exported together with the image into an Excel 

sheet for further analysis and processing (Excel is not a component of MCLII and is 

additionally required). 

 

 



13.7 Denoise 
13.8 Sharpening 
13.9 Color Assignment 
 
 
13.10 Filter 
Select Filter to apply one of the numerous filter functions in MCLII to the active image. You 

can also create custom filters and apply them using the filter commands. Each group of filters 

has its own property page or tab, whereby the filter type and the size can be selected. The 

filtered results are almost always written to the active image. You can use the Undo / Redo 

command to remove filter operations that have been applied. 

 

 

13.10.1 Image Enhance 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Low Pass: Use this filter to remove high-frequency information from the image (this has the 

effect of blurring sharp edges). The low-pass filter replaces the center pixel with the average 

value from its surroundings. This filter can also be used to remove noise. 

 

High Pass: Use this filter to improve high-frequency information. The high-pass filter replaces 

the center pixel with a folded value, which increases its contrast significantly to its 

surroundings. The high-pass filter leaves only elements with high contrast. 

 

Gauss: Use this filter to soften an image by turning off high-frequency information with a 

Gauss function. This has the effect of blurring sharp edges. The Gauss filter is similar to the 

low-pass filter, but it degrades the image less than the low-pass filter. 

 

High Gauss: Use this filter to improve the detail. This process is similar to the blurred masking 

technique (see sharpness filter), but it brings less noise into the picture. A Gaussian curve 

kernel is used. Available in 7x7 and 9x9 kernel sizes. 

 

Equalization: Use this filter to improve the contrast, based on the histogram of the local 

environment. 

 

Sharpness: Use this filter to improve fine details or refocus an image. The sharpness filter 

sharpens the image with the blurred masking technique. 



Flatten: no description 

 

Median: Use this filter to remove the impulse noise from an image. The median filter 

replaces the center pixel with the mean value in the environment. 

 

Rank:  Use this filter to remove impulse noise from an image. The pixels in the kernel are in 

order of intensity, and the pixel in this range is selected for comparison. For example, there 

are 25 pixels in a 5x5 kernel. A percentage of 95% would choose the second largest pixel for 

comparison. If the difference between the selected pixel and the center pixel is greater than 

the threshold, the filter replaces the value of the center pixel with the value of the selected 

pixel. 

 

Options 
When one of the filters is selected, the following options are displayed: 

 

3x3: creates a more subtle filter effect 

5x5: creates a more moderate filter effect 

7x7: creates a more extreme filter effect 

 

Passes: Filter is applied multiple times on the image. When a filter is applied multiple times, 

its effect is enhanced by each pass. An image softened by a pass of the low-pass filter is again 

softened by a second pass. 

 

Strength: Enter a value of 1-10 that determines the filter effect on the image. A value of 10 

specifies the full strength (100%) of the filtered result applied to each pixel. Values less than 

10 reduce the intensity of the filter. A value of 1 indicates that only 10% of the difference 

between the filtered pixel value and the original pixel value should be applied. A value of 2 

indicates that 20% of the difference should be applied, and so on. 

 

Rank: This value specifies which pixel is used in the sorted field to replace the central pixel. 

Pixels in the field are sorted in ascending order. The pixels are indexed from 0 to kernel size x 

kernel size-1. Pixel index 0 corresponds to the lowest pixel value. 

Rank is expressed as a percentage of the indexes (kernel size x kernel size-1). A 50% rank 

means the center of the field. 0% Rank means the lowest index (lowest gray value) and 100% 

rank means the highest index (highest gray value). 

 

If the Equalization Filter is selected, the options refer to the histogram distortion. 

Linear: This option distributes the histogram linearly over the intensity scale. This function 

creates a contrast-rich image with the highest possible dynamic range. 

 

Exponential: This option focuses the histogram at the top of the scale. This function produces 

a contrast-rich image. It is useful to increase the contrast in a very dark image. 

 

Logarithmic: This option focuses the histogram at the bottom of the scale. This function 

produces high contrast in an image with a low dynamic range. It tends to obscure the overall 

picture. It is useful to increase the contrast in a very bright picture. 

 

Best Fit: This option optimizes the values for the image. The results are achieved by 

stretching the local histogram to maximize the contrast between the brightest and darkest 

pixels in the local window area. 

 

Window: Image pixel statistics (minimum, maximum, histogram, average, standard 

deviation, etc.) are calculated on a small window of the image. These measurements are 



used to derive the local contrast for this region of the image. In short, a range of windows x 

windows around each pixel is all that is taken into account in changing the intensities in the 

image. Larger windows produce smoother results, while smaller windows more closely track 

small details. 

 

 

13.10.2 Edge Enhance 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Sobel: Use this filter to improve only the edges in an image. The Sobel Filter applies a 

mathematical formula to a 3x3 environment to locate and highlight its edges. 

 

Roberts: Use this filter to improve fine edges in an image. The Roberts filter is not a 

convolution filter. It is a mathematical formula on a 4x4 environment to produce its effects. 

The upper left pixel in the environment is replaced. 

 

Sculpt: Use this filter to apply a sculptural effect to the image. 

 

Laplace: No description 

 

Variance: No description 

 

Horizontal: Use this filter to detect and highlight horizontal edges. 

 

Vertical: Use this filter to detect and emphasize vertical edges. 

 

Options 
If one of the Edge Enhance filter is selected, the options are based on kernel size and filter 

strength. The following options are displayed: 

 

3x3: Select 3x3 kernel to create a more subtle filter effect 

5x5: creates a more moderate filter effect 

7x7: creates a more extreme filter effect 

 

Passes: Filter is applied multiple times on the image. When a filter is applied multiple times, 

its effect is enhanced by each pass. An image softened by a pass of the low-pass filter is again 

softened by a second pass. 



 

Strength:  Enter a value of 1-10 that determines the filter effect on the image. A value of 10 

specifies the full strength (100%) of the filtered result applied to each pixel. Values less than 

10 reduce the intensity of the filter. A value of 1 indicates that only 10% of the difference 

between the filtered pixel value and the original pixel value is to be applied. A value of 2 

indicates that 20% of the difference should be applied, and so on. 

If Sobel or Roberts is selected, no other options are available. 

 

 

13.10.3 Morphological 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Erode: Use this filter if you want to change the size of the objects in the image. The filter 

reduces the edges of the bright objects and increases the edges of the dark objects. 

 
Dilate: Use this filter if you want to resize the objects in the image. The filter expands bright 

objects and reduces dark objects. 

 
Open: Use this filter when you want to change the shape of objects in the image. Suppose 

the image contains bright objects on a dark field. Then the filter balances the object 

contours, separates closely connected objects, and removes small dark holes. 

 
Close: Use this filter when you want to change the shape of objects in the image. Suppose 

the image contains bright objects on a dark field. Then, the filter fills gaps and enlarges 

projections to connect objects that are close to each other. 

 
Top hat: Use this filter to recognize and emphasize dots or grains that are brighter than the 

background. For this processing there are 3 kernel sizes. Click the option box to change the 

kernel size to the value that most closely matches the size of the kernels. 

 
Well: Use this filter to recognize and emphasize dots or grains that are darker than the 

background. For this processing there are 3 kernel sizes. Click the option box to change the 

kernel size to the value that most closely matches the size of the kernels. 

 
Gradient: Use this filter to enhance the edges in an image. 

 
Distance: Use this filter to show the distances of pixels within drops to the outer boundaries 

of these drops. After the distance filter is applied, the background is black (i.e., pixels having 



a value of 0). Only the range within the drop has nonzero values (becomes white). The values 

of each pixel within the drop are a count of the shortest distance from that pixel to the edge 

of the drop. Thus, all pixels along the drop edge have a value of 1 (since they are one pixel 

from the edge of the droplet); Pixels having a distance of 2 from the edge have the value 2, 

and so on. This creates a distance map of the image. The distance filter does not work with 

True Color images. If you want to use the distance filter with a true color image, the image 

must be converted to grayscale. 

 
Thinning: Use this filter to reduce an image to its skeleton. When selecting the filter, the 

threshold value must be determined which determines whether a pixel is part of the subject 

or part of the background. The thinning filter does not work with True Color Images. If you 

want to thin the True Color image, it must first be converted to a grayscale image. 

 
Watershed: Use this filter to separate objects that touch each other. The infiltration filter 

reduces objects until they disappear. Then they are enlarged again, but without touching. 

The turn-point filter cannot separate objects in True Color images. If you want to separate 

objects in a True Color image, the image must first be converted to a grayscale image.  

 

Options 
When one of the Zoom, Expand, Open, or Close filters is selected, the options apply to the 

kernel size and shape. The following options are available: 

 

2x2 Square: Select this option to use the 2x2 square kernel configurations. 

3x1 Row: Select this option to use the 3x1 row kernel configurations. 

1x3 Column: Select this option to use the 1x3 column kernel configurations. 

3x3 Cross: Select this option to us the 3x3 cross kernel configurations. 

5x5 Circle: Select this option to use the 5x5 circle kernel configurations. 

7x7 Circle: Select this option to use the 7x7 circle kernel configurations. This is a two-pass 

filter, accomplished using a 5x5 circle followed by a 3x3 cross. 

11x11 Circle: Select this option to use the 11x11 circle kernel configurations. This is a three-

pass filter, accomplished by using a 5x5 circle followed by another 5x5 circle, followed by a 

3x3 cross. 

Passes: Set the number of filter iteration. 

 

Note: The circular kernels are more effective in round objects (cells, grains, etc.) because 

their circular configuration preserves the circular shape of the objects better than square 

configurations. 

 

If one of the Top Hat, Well, or Gradient filters is selected, the options are based on kernel 

size and shape. The following options are available: 

 

3x3: Select this option to use the 3x3 square kernel configurations. 

5x5: Select this option to use the 5x5 square kernel configurations. 

7x7: Select this option to use the 7x7 square kernel configurations. 

 

If one of the Watershed, Thinning, or Distance filters is selected, the options refer to the 

threshold. The following options are available: 

 

Threshold: Enter a percentage value of 1-100 indicating the intensity value to binarize the 

image. For example, a threshold value of 50% on a gray scale image would set all values ≤ 
127 to 0 (black) and all values ≥ 128 to the maximum value for this image class (white). 

  

 



13.10.4 Kernel 
The kernel page allows you to edit the kernel files for the morphological and convolution 

filters. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: The HighPass, LowPass, Laplace, and Unsharp kernels are used by the HighPass, 

LowPass, Laplace, and Sharpen options listed in the Image Enhancements dialog box (there is 

no difference between these options - The two methods ultimately make the same). Because 

these kernel files are essential to the operation of these filter options, they must not be 

deleted or renamed. 

 

Filter Type: Select the filter type you want to modify. 

 
Edit ...: Select "Edit" to modify the settings of the various kernels. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Name: In this window, you can change the name of the corresponding kernel. 

 
Kernel Size: In this window you can change the size of the corresponding kernel. 

 



Fill: Click this button to fill each element of the kernel with a specific value. The Fill dialog box 

appears. You can enter a value between 0 and 10. The fill key is useful to set all coefficients 

to the same value. You can then change the coefficients that require the same value. 

 
Offset: The pixel whose value is changed is usually the center pixel. However, you can change 

any pixel. MCLII marks the pixel to be changed by placing a marker. 

 
New ...: Select New to create a new filter core. The Edit Kernel dialog is displayed. The 

functions correspond to those of Edit (described above), except that the file name for the 

new kernel file must be specified. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Delete: Deletes the selected kernel. 

 
Options: The choice in this case depends on the kind of filter that is selected. 

 

 

13.11 Image Stacking 
The Image Stacking process is a form of speckle imaging commonly used to obtain high 

quality images from a number of short exposures with varying image shifts. It has been used 

in astronomy for several decades and is the basis for image stabilization in some cameras. 

The method involves calculating the differential shifts of the images. This is easily achieved in 

astronomical images, as they can be aligned with the stars. Once the images are aligned, they 

are averaged. It is a basic principle of statistics that the variation in a sample can be reduced 

by averaging the individual values. When using an average, the signal-to-noise ratio should 

be increased by a factor of the square root of the number of images. 

 

The Image Stacking method can also be used for the biological and fluorescent microscope 

image to capture the image-to-noise ratio (SNR) and the dynamic ranges. That is why we 

introduce the image stacking process in MicroCamLabII. 

 

The MCLII image stacking method introduces advanced image matching techniques for 

twisted, shifted, and scaled images. The user can record a short video to obtain a high-quality 

stacked image without taking picture rotation, displacement, and scaling between a series of 

images in the video. The steps of the image stacking process are as described below: 

 

1. Select Process -> Image Stacking. Then, as shown below, a Windows window opens. 

2. Select a video file from the open directory. In this case, we open "test.avi" for the 

demonstration. Click "Open" to open the file. 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Then an Image Stacking window opens in which the processing progress is displayed. 

4. If you click Cancel, the process is canceled. After stacking, a stacked image is displayed in 

a new window for further processing. In the stacked image, the signal-to-noise ratio is 

significantly improved. There are some black edges on the stacked image, because the 

image in the video is moved. Image areas which do not have corresponding pixels in the 

reference image are marked with a 0 (we select the first image in the video file as a 

reference image). 

 

Note: MCLII supports the following image stacking formats: wmv, asf, avi, mp4, m4v, 3gp, 

3g2, 3gp2, 3gpp, mov, mkv, flv, rm, rmvp. 

In the image stacking process, MCLII records the first frame as a reference image. That is, the 

first frame is very important and it should be ensured that this frame is the right picture 

scene. The following frames should have a larger overlap range than the first frame. 

 

13.12 Line Profile 
Select Process -> Line Profile to visualize how pixels are distributed along a selected line by 

graphically displaying the number of pixels at each color intensity step. 

 

Select Measurements -> Line -> Any Line / Horizontal or Vertical Line to draw a line on the 

image. If you select Process -> Line Profile again, a line profile graph is displayed. (procedure 

can also be executed in reverse): 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Line profile: In a line profile, the X-axis represents the spatial scale and the Y-axis represents 

the intensity values ranging from 0 to 255. If the image is a gray scale image, the gray value is 

displayed. If the image is an HSV color image, the R, G, and B values are displayed separately 

with the corresponding R, G, and B color. 

 

Background: Open the Windows color dialog to set the background color of the profile 

window. 

 

Title: Use this command to give the line profile a title. 

 
Recording: Recording the picture line profile as a new picture 

 
Copy: Copy the line profile image to a clipboard. 

 
Save As: Save the Line Profile image in bmp format. 

 

 

13.13 Surface Plot 
Note: This option is only enabled by using a gray scale image 

 

 Select Process -> Surface Plot (or 3-D Setup). The function creates a 3D representation of the 

surface intensity of an image. When selecting the "Surface Plot" command, note that X = 

image, where Y = image height and Z = pixel is the gray value. 

 

In the view window, you can adjust the elevation and rotation of the image by dragging the 

mouse. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Position Solid: The left input window displays the relative position of the entire image in the 

view window whose default value is 0.5. The right input window indicates the relative height 

of the Z scale display, the default value of which is 1. 

 

Reset: Resets the values in the input windows Position Solid to the default values. 

 

Image Background Color: Choose this option to select a color to adjust the background color 

of the viewport. 



 

Capture: Capture the active image in the view window as a new image. 

 

Color Table: Select the colors to map the gray values found in the surface drawing. The 

button at each end of the color panel opens the color dialog by selecting the start and end 

colors of the area. (Please refer to Preudo Color for more information) 

 

 

13.14 Pseude Color 
Note: This option is only enabled by using a grey scale image. 

 

Select Process -> Pseudo Color to colorize the active monochromatic image. This is used to 

highlight certain features in a greyscale image, such as displaying all densities above a 

particular point in red, or the recorded thermal information. All temperatures below a 

certain point can be displayed in blue. 

 

 

 

 

 

 

 

 

 

 

 

When a monochromatic image is processed with the Pseudo Color function, a special palette 

has to be created which the monochromatic image is to be displayed with. Due to the 

pseudo-coloring of an image, the pixel value in the image is not changed (it does not convert 

an image into the correct color or palette). It simply associates a pseudo color palette with 

the image that interprets the gray scale values in the image as a color. 

 

Pseudo color images are very similar in structure to the palette-class images, but there are a 

few important differences. First, the pixel values in a pseudo-color image actually represent 

continuous tone intensity information, palette image pixels not carrying any intensity signals. 

Second, a color palette image contains a color palette table that is actually part of the image 

file. 

 

Various colors can be selected to display the gray values. The buttons at each end of the 

color strips display the color dialog separately, which allows the start and end colors of the 

area to be selected. 

 

 

13.15 Range 
You can use the Process -> Range command to adjust the intensity levels of the image to 

increase the contrast and increase the display in low light situations. Select the Range 

command to open the corresponding dialog. 

 

Two vertical markers show the upper and lower limits of the intensity levels. These markers 

can be moved with the mouse by the Drag & Drop method. For a color image, the histogram 

will display the red, green, and blue values with appropriate color lines. 

 



 

 

 

 

 

 

 

 

 

 

Two Edit controls specify the values of the intensity levels. Select Up / Down buttons to 

increase or decrease these values. All values between 0 and the lower limit are black, and all 

values between the upper limit and the upper end of the scale are white. These two 

processing values, which correspond to the two vertical markers, indicate the upper and 

lower limit values of the intensity stages. The default values are 0 and 255. 

 

Reset: Use the Reset button to reset the black and white values to the high and low end of 

the dynamic range. 

 

Best Fit: The Best Fit button automatically adjusts the intensity levels to the optimum value 

and instructs MCLII to optimize the brightness and contrast values for the respective image. 

 

Invert: The Invert button reverses the color of the image. 

 

Update: Update will refresh the display Range with the most current image information. 

 

 

 

 

13.16 Binary 
Binary is a kind of gray-level process. If the gray of the pixel is larger than the predetermined 

threshold, the pixel color is changed to white. Otherwise the pixel color is changed to black. 

Although some information may be lost during the process, it is an important step for other 

processes. 

 

 

 

 

 

 

 

 

 

 

The curve in the binary dialog shows the gray distribution of the image. 

 

The line in the dialog shows the threshold value. Drag the line to change the threshold, or 

change the value in the input field (in the upper left corner of the dialog) to move the line. 

 

The input field shows the current value position of the line. If you change the value, the line 

is moved at the same time; 

 



Click Best Fit to apply the automatic threshold to the image. An automatic threshold is used 

to display the image in the optimal gray scale ratio. 

 

 

 

14. Layer 
 

14.1 About Layer 
MCLII Layer works like several layers of slides, where the original background remains visible. 

Each film layer contains different information, which gives an overall picture. These layers 

can be added and removed as desired. 

You can use layers to perform tasks. For example, to perform the measurement on the image 

without polluting the image and save it for further analysis, adding text to an image, or 

adding vector graphic shapes. 

 

14.2 Organizing Layers 
A new image has a single layer called Background Layer. The number of additional layers that 

you can add to an image is limited only by the memory of your device. You work with layers 

in the sidebar. The Layer Sidebar helps you organize and manage the layers, just like the 

Layer Menu. 

 

 

14.3 Layers for non-destructive measurement and label 
Instead of directly editing pixels, you can label and measure the image without changing the 

underlying pixels. Since no pixels are changed, you can easily remove the measurement 

objects and labels. 

 

 

 

 

14.4 Layer Menu & Sidebar 
The Layer Menu and Sidebar contain the same functions. In the sidebar, you can access them 

with the right mouse button.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

New: Setup a new Layer 

 

 

 

 

 

 

 

 

Remove: Remove the non-current Layer 

 

 

 

 

 

 

 

 

 

Current: Set the selected Layer as the Current Layer 

 

 

 

 

 

 

 

 

 

 

Show/Hide: Set the non-current Layer Visible or Invisible. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Rename: rename a Layer 

 

 

 

 

 



 

Export to Image: Export all the Layers measurement Objects to the image. This cannot be 

removed anymore. 

 

Export to Microsoft Excel: Export the image and all the Objects on the Current Layer to the 

Excel File (Excel is not a component of MCLII and is additionally required).  

 
 

15. Measurements 
 

With the Measurement Menu items you can easily measure the image with many geometric 

shapes. 

MCLII uses the Layer technique to perform the measurements. This does not result in any 

contamination or damage to the image pixels. The Measurement menus and their submenus 

are shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.1 Object Select 
The Option Measurements -> Select Objects or the corresponding button in the toolbar is 

activated only if a new measurement is carried out via the background level. 

After the measurement has been performed on the respective level, select this menu to 

select the objects. 

 

1. The object is selected by clicking on it. 

2. Select a group of objects by placing them in a rectangular area with the object selection 

command (left mouse button and dragging), or by pressing the Shift key and clicking the 

objects with the left mouse button until all the desired objects are selected. 

 

 

 

 



15.2 Angle 
1. Move the mouse to the beginning point of the angle. Select the point by clicking with the 

left mouse button. 

2. Now move the mouse to the vertex of the angle and select it again by clicking the left 

mouse button. 

3. Finally, move the mouse to the end point of the angle and select the end point again by 

clicking with the left mouse button. A label is displayed near the vertex. 

 

 

 

 

 

 

 

 

 

 

 

 

15.3 Point 
Move the mouse to the displayed point and click with the left mouse button to highlight it. 

Now the point is marked with a label and the X and Y coordinates are displayed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.4 Line 
 

15.4.1 Arbitrary line 
Draw Arbitrary Line between two points on the specified Layer. 

 

1. Select Measurements -> Line -> Arbitrary Line 

2. Move the mouse to the beginning of the line and click the left mouse button to 

select the point. 

3. Move the mouse to the end point of the line and click again with the left mouse 

button to select the point. You will now see a line labeled L1 and length. 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.4.2 Horizontal Line 
Draw a horizontal line between two points on the specified plane. 

The starting point, as in the case of the Arbitrary Line, is defined by a click with the 

left mouse button. Now the line can be drawn automatically to the horizontal. The 

end point is determined by a click with the left mouse button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.4.3 Vertical Line 
Draw a vertical line between two points on the specified object. The starting point is 

set again by clicking with the left mouse button. Now the line can be drawn 

automatically to the vertical. The end point is determined by a click with the left 

mouse button. 

 

 

 

 

 

 

 

 

 

 

 

 



15.5 Parallel 
1. Select Measurement -> Parellel 
2. Move the mouse and click with the left mouse button to select a point. 

3. Move the mouse to the desired end point and highlight it again with the left mouse 

button. 

4. Now move the mouse to the starting point of the parallels and then highlight it with the 

left mouse button. 

5. If you now drag the mouse to the end point, the line can only be drawn as a parallel to 

the first line. Click the left mouse button again to set the end point. 

6. To cancel the current operation, click the right mouse button once. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.6 Vertical 
 

15.6.1 Four points 
1. Move the mouse and select the starting point with the left mouse button. 

2. Move the mouse and select the second point with the left mouse button. The 

two points are now connected by a line. 

3. Move the mouse to select the third point. 

4. If you now move the mouse around the fourth point, the line can only be drawn 

vertically (depending on the orientation of the first line) to the first line (points 1 

and 2). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

15.6.2 Three Points 
1. Move the mouse and select the starting point with the left mouse button. 

2. Move the mouse and select the second point with the left mouse button. The 

two points are now connected by a line. 

3. If you move the mouse again to set the third point, the second line can only be 

drawn vertically (depending on the orientation of the first line) to the first line. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.7 Rectangle 
1. Move the mouse to the start point of the rectangle and click with the left mouse button. 

2. Move the mouse to a second point to align the rectangle. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.8 Round Rectangle 
1. Use this function to measure a rounded rectangle. 

2. Select Measurement -> Round Rectangle to highlight the round rectangle. 

3. Move the mouse to the start point and click the left mouse button to highlight the point. 

4. Move the mouse to a second point to set the size of the round rectangle, and then 

highlight the point with the left mouse button. You will now see a round rectangle 

named Rr1 and height and width in two dimensions. 

 

 



15.9 Ellipse 
1. Select Measurement -> Ellipse 

2. Move the mouse to select the first point with the left mouse button. 

3. Move the mouse to the second point to highlight it again with the left mouse button. 

The ellipse is drawn by the movement with the mouse. 

4. If the ellipse does not completely overlay the object on the image, select Measurements 
-> Select Object to adjust the ellipse. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.10 Circle 
 

15.10.1 Center + Radius 
Select Measurements -> Circle -> Center + Radius to draw a circle with center and 

radius function on the corresponding layer. Move the mouse to the center of the 

circle and click the left mouse button. The selected point marks the center of the 

circle and can be resized by moving the mouse. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.10.2 Two points 
Select Measurements -> Circle -> Two Points to draw a circle with two points on the 

corresponding level. Move the mouse to the edge of the circle to be drawn and click 



the left mouse button. The selected point marks the edge of the circle and can be 

resized by moving the mouse in size and orientation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.10.3 Three points 
Select Measurements -> Circle -> Three points to draw a circle with three points on 

the corresponding level. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.11 Annulus 
1. Move the mouse to the center of the ring and click the left mouse button to highlight the 

center point. 

2. Move the mouse to resize the ring to the perimeter of the object, and then click the left 

mouse button again. 



3. Move the mouse again to adjust the second ring to the inner diameter of the circle. Now 

you will see the diameter of the two drawn rings. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.12 Two Circles 
 

15.12.1 Center + Radius 
1. Move the mouse to the center of the circle and click the left mouse button to 

highlight the center point. 

2. Now move the mouse to adjust the size of the circle to the perimeter of the 

object, and click the left mouse button again. 

3. Now move the mouse to the center of the second circle and click the left mouse 

button again to select the center point and then resize it by moving the mouse. 

After both circles have been drawn, a connection is drawn between the two 

circle centers. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



15.12.2 Three points 
Draw two circles with the three-point method at the appropriate level. After both 

circles are drawn, a connection is drawn between the two circle centers. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.13 Arc 
Select Measurements -> Arc to draw one or more Arcs on the appropriate layer. 

 

1. Move the mouse to the start point of the arc and click the left mouse button to select the 

first point. 

2. Move the mouse to another point of the arc (at best to the center of the arc) and click 

again with the left mouse button to highlight the point. 

3. Move the mouse to a third and last point of the arc and click the left mouse button. The 

line now adjusts to the selected points and becomes a bow. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

15.14 Text 
Select Measurements -> Text to insert a text field at the appropriate level. 

 

1. Move the mouse to the start point of the text window and click the left mouse button to 

select the point. 

2. Move the mouse to another point and click the left mouse button again to set the size of 

the text window. 

3. Then a text window opens in which you can insert the desired text. The settings for the 

font, size and color can be adjusted via the sidebar. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.15 Polygon 
Select Measurements -> Polygon to draw a shape around a polygon at the appropriate level. 

 

1. Move the mouse to any starting point of the object and click the left mouse button to 

select the point. 

2. Move the mouse to another point of the polygon and click again with the left mouse 

button to highlight the point. The marked points are connected by a line. Repeat this 

procedure as many times as necessary until the object is completely outlined. The 

narrower the dots are, the closer the outline becomes. 

3. When the outline is complete, close the polygon function with the right mouse button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



15.16 Curve 
 

15.16.1 Mode 1 
1. Move the mouse to the desired starting point and hold down the left mouse 

button. 

2. Use the left mouse button to move the mouse along the test object until it is 

completely framed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.16.2 Mode 2 
1. Move the mouse to the starting point of the measurement object and click the 

left mouse button. 

2. Move the mouse to the next point and click the left mouse button again. Repeat 

this process as often as necessary until the object is measured (operation similar 

to the polygon). The shorter the distances between the set points, the more  

accurate the measurement becomes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: Both operations are completed with the right mouse button. 

 

 

 

 

 



15.17 Scale Bar 
Select the Scale Bar to add a scale (in pixels) to the image. There is no description available in 

the english manual. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.18 Z Order 
Top: Change the position of the selected object to the top of all objects in the current layer. 

Bottom: Change the position of the selected object to the lowest point of all objects in the 

current layer. 

Move Up: Change the position of the selected object to the top of the two at the current 

level. 

Move Down: Change the position of the selected object to the lower point of the two on the 

current level. 

 

Notes for the measurements: 
a) To check or modify the parameters of an object, select a single object. The Sidebar with 

the details of appearance, calculation and coordinates is activated automatically. Here 

you can edit the corresponding object parameters to change their properties. 

b) The appearance and the coordinates in the sidebar are only activated when a single 

object is selected. The calculation is for a single object, or it multiplies all selected 

objects. The calculated elements depend on the selected object type (the type can be the 

same or different) 

c) To cancel or finish a measurement, click the right mouse button. 

 

 

 

16 Options 
 

16.1 Preferences 
In the presets, there are 7 different sections in the side bar of the window. These are quick 

storage, file, print, grid, cursor, recording and miscellaneous. 

 

 

 

 

 



16.1.1 Quick Save 
The Quick Save menu or icon is activated when a new image has been captured with 

the camera, or a picture window is created by selecting File> Paste as New File. 

File -> Quick Save can save the file quickly, without specifying file directory, file name 

and file format. The settings are specified in Options> Preferences> Quick Save. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Directory: Specifies the file path in which folder the image files are stored in Quick 
Save. 

 

Name Format: Select the file name to be used for Quick Save. 

A number sequence (nnnn) and various date formats (e.g., yyyymmdd) may be 

selected. 

 

File Prefix: When creating file names for a series of images, enter a filename prefix 

for fast storage. This prefix is used with the name format to form a final filename 

paradigma. 

 

File Type: In this combo box you can select the format in which the image should be 

saved (BMP, JPG, PNG, TIF). Click on the option button to set the various parameters 

for the encoding of the file (for the BMP format, the option is disabled. See File -> 
Save As for details on the format encoding method); If there are objects on the 

screen, the file type is selected as MCLII file type (* .tft)". 

 

Sample: The final name is indicated to the right of the sample label. 

 

Show the rename dialog: The file can be renamed after this term. When this item is 

selected, a rename dialog appears after selecting File -> Quick Save, or click the 

Quick Save icon on the toolbar. The new name can be specified again according to 

the request. 

 

 

 

 

 

 



16.1.2 File 
You can extend a file for the specified file format and its abbreviation to determine 

whether or not it is displayed in the Browse window (the checked format can be 

displayed in the Browse window). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Extension: Used to identify file extension. 

Format: The English name of the file format. 

Abbr: Abbreviation of the file format. 

Browse: To determine whether the file format can be displayed in the "Browse" 

window. 

 

Configuration: To configure the image file as an option for JPEG, Portable Network 

Graphics, Tag Image File Format, CompuServ, JPEG 2000 Standard, JPEG Codestream. 

For more information, see the File -> Save As dialog box on the Option button. 

 

 

 

16.1.3 Print 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



You can set the Page Header and Page Footer in the following format: 

 

& F: filename 

& P: Current page 

& P: All pages 

% A: Full weekday name 

% B: Abbreviated month name 

% B: Full month name 

% C: Date and time plot for locale 

% D: day and month as decimal 

% H: Time in 24 hour format (00 - 23) 

% I: Time in 12h. Format (01 -12) 

% J: Anniversary as decimal number (001 - 366) 

% M: Month as decimal (01 - 12) 

% M: Minute as decimal (00 - 59) 

% P: Current local time A.M: /P.M. 

% S: second as decimal 

% U: Year week as decimal number, Sunday as first weekday (00 - 53) 

% W: Weekday as decimal number (0 - 6, Sunday corresponds to 0) 

% W: Year week as decimal number Monday as first weekday (00 - 53) 

% X: Date representation for current locale 

% X: Time representation for current locale 

% Y: Year without century as decimal (00 - 99) 

% Y: Year without century as decimal number 

% Z% Z: Timezone abbreviation, only if timezone is known 

%%: Percentage sign 

 

For example: If you select &f Date:% Y-% m-% d, the file name and date are printed 

in the yyyy-mm-dd format in the header line. 

If you select Page: & p / & P, 01/11 is printed in the footer (Assuming the current 

page is page 1 and the page is 11). 

Print measurement items: If the measurement object overlays the image 

superimposed, check these objects on the image. Measurement sheet on the side; 

Print measurement chart: If the measurement object is superimposed on the image, 

check whether it prints these objects. Measurement sheet on the side with; 

Always use different paper: print the measurement data on a new page; 

Auto: Print the measured data directly behind the image (if the image and the 

measurement data can be arranged on a single page), on a separate page (if not); 

Never use other paper: print the data sheet directly behind the image page; 

Font: Select the font for the data. 

 

 

 

 

 

 

 

 

 

 

 

 

 



  16.1.4 Grids 
When you select View -> Grid -> Settings, or Options -> Preferences -> Grids, the 

same settings are displayed. 

There you can select the grid style, the line style and the line color for the grid. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

16.1.5 Cursor 
This command will set the mouse cursor for the video and image window operations. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the horizontal cross in: 
None (Window Standard), Single (Single Line), Double (1 pixel), Double (3 pixels), 

Double (5 pixels), Double (7 pixels) and Double (9 pixels) formats. 

 

Select the vertical cross in: 
None (Window Standard), Single (Single Line), Double (1 pixel), Double (3 pixels), 

Double (5 pixels), Double (7 pixels) and Double (9 pixels) formats. 



Single means Simple Line. Double means two parallel lines. 1 pixel means that the 

line space between the two lines is 1 pixel in the distance. The other sizes also have 

this meaning. 

 

Select the cursor shape from cross, point and zero. 

In the following figure, a cursor with a double horizontal and vertical line is 

intersected with 9 pixels (for the alignment application the longer one) and the 

cursor is defined as a cross. 

 

 

16.1.6 Capture 
If you want to capture an image from the video filter with many superimposed 

measurement objects, the following setting should be defined first. 

 

1. If you select Options -> Preferences, the window below appears 

2. Now you can choose between Capture with Marker and Watermark and 

Capture with Measurement. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

16.1.7 Misc 
The Miscellaneous item is mainly used to control MCLII UI. It contains the settings: 

 

MicrCamLabII Warnings for special file formats 

Sidebars 

UI Style 

Language 

Enable GPU accelerated image processing  

Privacy 

 

 

 

 

 

 

 

 

 



16.2 Measurement  
Select Options -> Measurement 

 

16.2.1 General 
The calculation results keep: The selection allows you to set the calculation results to 

1-6 decimal places. The default is 2 decimal places. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Label font size:  Font size and kind for the measurement label 

 
Label color: Color of measurements und labels 

 

Dimensions with unit: If this function is selected, the dimension is displayed 

together with the unit of measurement objects. If the function is not selected, only 

the dimension with the measurement objects is displayed. 

 

Label with name: If you select Label with name, a prefix is added before the 

measurement object number. The prefix for the other object can be specified in the 

measurement page bar where an item is named Name. 

 

 

16.2.2 Length Unit 
Here you can select the Length Unit for the measurement object on one layer. 

 

 

 

 

 

 

 

 

 

 

 

 



Unit: The unit defined by MCLII. This cannot be deleted. 

Current: The selected unit. 

Type: Type of unit. This can be specified as System (defined by MCLII) or User 

(defined by the user). 

Symbol: Abbreviation of the unit.  

Scale: Represents the ratio of meter to unit. For example, if the unit is μm, then 

meters in μm should be 100.000, the scale should be 1e + 6; 

 

Add Unit: The user can also define own units. Click the Add button and the Add Unit 

dialog box opens. Here you can enter the units Name and Symbol in the fields. In the 

example shown, we enter the name decimeter and the symbol dm. The scale for 

meters in decimeter is 10. Click OK to add or cancel the entry. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The specified type is now user. This means that this unit is not defined by the system, 

but by the user. 

 

 

 

16.2.3 Angle Unit 
On the Angle Unit page you can select Radian, Degree, or PI as the angle unit. Display 

all the angular units in the measurement sidebar to display all of the objects listed as 

a reference in the scale bar as shown above. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



16.2.4 Sheet 
Select View -> Measurement Sheet to understand the functions. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. To select the dimensions, click on the corresponding position. The up or down 

buttons are activated. 

2. By selecting or unselecting the units, they are displayed or blanked in the 

Measurement Sheet. 

3. By clicking on Preferences, the information is reset to the default. Index and 

Name remain unaffected. 

 

Note: The position index and the name are always grayed out and cannot be 

deselected. This means that these two elements cannot be changed. 

 

 

16.2.5 Object 
Object lists the features of point, line, parallel, two-parallel, vertical, angle, rectangle, 

circular, arc, annulus, two-circle, ellipse, polygon, Scales and text. 

By clicking Preferences, all changes are reset to the default. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



16.3 Magnifications 
Select Options -> Magnification to manage the calibrated magnifications. 

For example, if the 4x, 10x, 40x, 100x magnifications were defined, the magnification dialog 

should look as follows. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. If you select a resolution in the list, the Delete ... button is activated and you can 

delete it. The Up and Down buttons are also activated. 

2. Select Delete All to delete all specified magnifications. 

3. If you want to use the magnification later, you should first make a backup. 

4. Click Export ... to save the magnifications in a media. The file extension is then *. 

Magn file. 

5. After the new installation is complete, the magnification can be imported by 

selecting Options -> Magnification ... and clicking Import to load the previously 

saved * .magn file. 

6. When everything is OK, press OK to close the magnification dialog box. 

 

 

 

16.4 Calibrate 
 

1. Open MCLII 

2. Connect the camera to the computer and the microscope. 

3. Start the camera (in this case, UCMOS00350KPA) 

4. Switch the microscope object to 10x and place the TS-M1 micrometer in the center of 

the microscope field. Try to focus the ruler. Set the unit to Pixels, the video resolution to 

the maximum (2048x1536 for UCMOS03100KPA) and the zoom ratio to 100%. 

 

 

 

 

 

 

 

 

 

 



5. If you select Options -> Calibration ... or click on the corresponding symbol in the 

toolbar, a red line with a pixel number and 0.000μm length will be superimposed on the 

video window. At the same time, a dialogue called Calibration is displayed in the video 

window. 

6. Try to align the two ends of the red line with the video ruler scale (try to pull the red line 

as long as possible to maintain the calibration accuracy); 

7. Enter the current microscope lens or select it in the magnification field. The current 

magnification is 10x. 

8. Read the superimposed (by the red line) micro-ruler length and enter it in the field 

Current length. This current length is also displayed in the middle of the red line just 

behind the pixel number. Simultaneously, the resolution in the resolution field is 

simulated and displayed. 

9. When everything is ok, click OK to complete the calibration. The 10x magnification is 

available in the magnification dropdown combo box on the toolbar of the video window. 

10. If you want to perform the measurement under this magnification, first select 10x in the 

above magnification drop-down combo box. Then, select Unit from the Unit drop-down 

list box, which is just to the left of the expansion drop-down combo box. (The user can 

also choose from the menu Options -> Measurements ...) A dialog with the name 

Measurement is called up. Click on the Unit of Length to check the unit of the current 

position. 

11. Now you can measure the objects with the selected unit. 

12. The selected resolution can be stored for future measurements. Once the measurements 

have been made on this video, the objects and resolution in the image can be saved with 

MicroCamLabII file format (* .tft) for future applications. 

13. The further magnification (4x, 40x, 100x) can be defined as well as the above steps. So 

when you switch the microscope lens, you only need to select the magnification on the 

toolbar to perform the measurement. 

 

 

 

16.5 Edit Dye List 
The Dye List can be used for the Process -> Color Composite function. The new Dye List 

Feature in MCLII allows you to select from a list of Dyes or to add their own custom Dyes to 

the list. The list of colors (toupview.dye) is stored in C: / ProgramFiles / TubeTek / 
ToupView. 

 

If you select Options -> Edit Dye List ..., the Edit Dye List dialog box opens: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



The list contains all the definitions that are in the current field of view. When this function is 

used to select a particular dye, the list displays the currently selected dye. You can also select 

a color from the drop-down list. 

 

Name: The list contains all the definitions that are in the current field of view. You can select 

a different dye from the drop-down list, and all other controls are updated to display the 

properties of the new color. 

 

Extraction Wavelength: Displays the default wavelength for your dye. You can adjust the 

wavelength by entering a new value. 

 

Emission wavelength: This field displays the emission wavelength for the selected dye. You 

can set the emission wavelength by entering a new value. The standard color changes in 

response to the changes in the emission wavelength. 

 

Color: Use the slider to adjust the emission wavelength for your dye. This also defines the 

default color. (You can also use the Color key to select a specific color using a standard 

Windows Color Selection dialog). The color changes in response to the changes in the 

emission wavelength. Here you can change the color associated with the selected color, or 

set a custom color. The default color is linked to the wavelength selection for your dye. If you 

change the emission wavelength, the displayed color is the default color for that wavelength. 

To specify a custom color, you should set the wavelength first and then edit the color. 

 

When you click New, a new color is created, which opens a dialog box named New Dye. Enter 

your new Dye name and click OK to exit the dialog, click Cancel to abort the entry. You are 

now returned to the color list and the new name is the default name in the name list. Try to 

set the emission wavelength, extraction wavelength, and color for your new dye. 

 

Save: Click Save to save your color selection. 

Close: Click Close to close the hue selection. 

 

 

 

16.6 Auto Correction 
Set the low and high clipping for the Image -> Settings -> Auto Level and Image -> Adjust -> 
Auto Contrast settings. The default value is 0.5% for both, but MicroCamLabII suggests that 

this value should be between 0 and 0.0999.  

 

 

 

 

 

 

 

 

 

 

 

 

See Image -> Settings -> Auto Level and Image> Adjust> Auto Contrast for more details. 

 

 

 



 

17. Window 
 

17.1 Close All 
Select Window -> Close All to close all open windows (including the camera) in MCLII. If 

changes have not been saved, you will be asked if you want to save them, and then you can 

select the direction. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

17.2 Reset Window Layout 
When you select this command, the MCLII window will be reset to the original. The reset will 

take effect after restarting. 

 

 

17.3 Window… 
Select Window -> Window ... opens a dialog box where you can manage the currently open 

windows. 

The dialog allows you to manage large lists of open windows. Let's say you have eight 

windows open, but want to close four of them scattered through the list. 

 

1. Select Window -> Window 

2. Select the windows you want to close. Hold Ctrl or Shift (Shift) key to select more than 

one at a time. In the example, four windows are selected. 

3. Click Close Window to close the selected window. The remaining windows are excluded 

from the operation and opened for further processing. 

 

 

 

18. Help 
 

18.1 Help Content 
Select Help -> Help Contents to open the MCLII Help file. The help file is a PDF document. If 

your computer does not install the PDF Reader, download the program from the following 

pages: http://www.adobe.com/downloads 

 

 

 

 

 

 

 



19. Über 
Select About -> About to view the corresponding information about MicroCamLabII, 

including MCLII version, compatibility, built date, and its developer www, etc. 

 

If you click on the URL link, you will be taken to the address of the camera manufacturer. If 

you have problems with the camera or MCLII, please contact your supplier. 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


